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About this Documentation
Types of Topics

1 About this Documentation

This section contains some introductory information on this documentation.

1.1 Types of Topics

The types of topics include concepts and operating instructions.

Type of topic Contents Title

Concept Explains the "What". without a verb as in
"Reports" or with a gerund

as in Installing and

Starting myReports.
Operating Describe task-oriented application Starts with "How to"
instructions cases — i.e., the "How" — and assumes |followed by a verb, as in

familiarity with the associated concepts. | How to Add a Report
Template.

1.2 Display Conventions

This documentation uses a variety of methods to present different types of
information.

Type of information Presentation Example
User Interface Elements Bold Click on OK.
Menu sequence > File > Exit
Special emphasis Bold Do not delete Name.
Cross-reference text Italics You will find more

information in the
topicNetwork.

Output Monospace font, e.g., Command not found.
Courier
Input Monospace font, e.g., Enter LOCAL as the file

Courier

name.

Key combination

Monospace font, e.g.,
Courier

<Ctrl>+<Alt>+<Esc>
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myReports

2 Introduction

This document is intended for the users of myReports and describes its
installation, configuration and operation.

2.1 myReports

myReports is an application for creating reports on Contact Center agents and
their activities, including calls, queues, performance, GOS (Grade of Service) and
wrap-up codes.

myReports offers the following features:

e More than 100 predefined report templates sorted by subject area (report
groups) for the creation of reports

* Schedules for the scheduled generation of reports
* Immediate or scheduled sending of reports by e-mail
e Scheduled export of reports

e Output formats for report previews, sent e-mails and exported reports: Excel,
PDF, and Word

* Report preview to check a report to be created in the desired output format.

Backup and Restore

When the data of the communication system is backed up and restored, the
reports and schedules of myReports are also taken into account.

2.2 User Interface Elements
The user interface of myReports consists of the main window with different areas.

The main window consists of the following elements:

A31003-P3010-U107-17-7619, 06/2015
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Administration

L) Schedule Manager \ P Report Manager \ 8 wys

& Available Reports
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{4 ANl User Calls (By Agent)

@@ CallHistory
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@@ Wrap-up Codes
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Average Grade Of Service By Agent
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Run this scheduled task at
[v]
() Hourly Recurrence
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() Weekly Recurrence

() Morthly Recurrence
() Yearly Recurrence

. 3 s
B  Pieie Matin

Schedules for selected report :

<- Please select a schedule -» ht
Output
Format
POF vl O © 4|
‘1 7186 ‘T‘
i

Daily Recurrence

1 Day(s).

(®) Every Weekday

) Every

|

B >

a,

Status : <8 Connected

myReports - 6.2.3 :: Java 1.7.0_51

17:17:15 07.03.2014

¢ Menu bar (1) with the menus

File
Administration
Help

and the name of the logged in user.

Menu items can also be invoked via the keyboard shortcuts next to each

menu item.
Function menu (2) with the symbols:

Symbol

Function

&

Schedule Manager

=

Report Manager

Iy

My Schedules

¢ Report Explorer (3): only in connection with Schedule Manager
Contains all report templates in a tree structure, grouped with emphasis on
content.

¢ Workspace (4): only in connection with Schedule Manager

Symbol

Function

A

Report Parameters

The display of the other icons depends on the selected function.
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e Status bar (5), with information on
— the connection status to the OpenScape Office server.
— Date and Time.

Tooltips

Tooltips are tiny windows in which myReports displays more information on
certain objects of the graphical user interface such as icons, for example. A tool
tip appears when you let the mouse pointer hover over the corresponding object
for some time.

Related Topics
* Reports
+ Schedules

A31003-P3010-U107-17-7619, 06/2015
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Installing and Starting myReports
How to Install myReports

3 Installing and Starting myReports

This section provides you with details on the hardware and software prerequisites
for myReports, the procedures for installing and starting myReports, and on
updates and upgrades.

NOTICE: Please make sure that you refer to the notes in the
ReadMe first file, which is located in the storage directory of
the install files.

Password

The password applies to myReports, myAgent, myAttendant, myPortal for
Desktop, myPortal for Outlook and Fax Printer as well as phone access to your
voicemail box.

You cannot change the password in myReports. The password can only be
changed in myAgent, myAttendant, myPortal for Desktop and myPortal for
Outlook or via the phone menu of the voicemail box.

License

The license permits the parallel installation of myReports for multiple users. Only
one user can use myReports at any given time.

Switching the User

You can switch the user without exiting myReports.

Automatic Login

You can use the automatic login if you want to start myReports without having to
log in via the Login window.

NOTICE: You should use the automatic login only if you are
certain that no-one else has access to your Windows user
account. Otherwise, unauthorized users could, for example,
potentially access your voicemails and fax messages or redirect
your station number to external toll-based destinations.

3.1 How to Install myReports

Prerequisites
* Your Windows user account has local administration rights for the installation.

* The installation file is available to you.

A31003-P3010-U107-17-7619, 06/2015
myReports, User Guide 9



Installing and Starting myReports

How to Start myReports

Step by Step

Next steps

1)
2

3

INFO: Please make sure that you refer to the notes in the
ReadMe first file.

Perform the installation.

If the User Account Control window appears with the message an
unidentified program wants access to your computer, click
Allow.

Follow the instructions of the Installation program.

Activate the license for myReports.

Related Topics

How to Start myReports
How to Uninstall myReports

3.2 How to Start myReports

Prerequisites

Step by Step

10

1)

2

3

You are an agent of the Contact Center with the authorization level (class of
service) of a supervisor or an administrator.

myReports is installed on your PC.
The license for myReports has been activated.

myReports was not started by any other user.

Click Start > Program Files > Communication Clients > myReports. You
will then be presented with the login screen.

Enter your user name in the Login Name field. This is usually your call
number. If you have any questions, please contact the administrator of your
communication system.

Enter your password, which must consist of only digits, in the Password field.
The default password when logging in for the first time is 1234. If you have
any questions, please contact the administrator of your communication
system.

NOTICE: If the wrong password is entered five times, access to
all Contact Center and UC Suite clients will be locked. Unlocking

A31003-P3010-U107-17-7619, 06/2015
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How to Switch Users

is only possible by the administrator of your communication
system.

4) If you want to use myReports with an automatic login in the future, enable the
Save Password check box. You can change this option at any time; see How
to Deactivate the Automatic Login.

NOTICE: You should use the automatic login only if you are
certain that no-one else has access to your Windows user
account. Otherwise, unauthorized users could, for example,
potentially access your voicemails and fax messages or redirect
your station number to external toll-based destinations.

5) In the Server Address field, enter the IP address of your application server
(if this is not already displayed).

6) Click Login.

Related Topics

* How to Install myReports

* How to Switch Users

+ How to Deactivate the Automatic Login

3.3 How to Switch Users

Prerequisites

Step by Step

* myReports was started.

1) Click File > Logout The Login window appears.
2) Login (see How to Start myReports, as of step 2).

Related Topics
* How to Start myReports

3.4 How to Deactivate the Automatic Login

Prerequisites

* myReports was started.

A31003-P3010-U107-17-7619, 06/2015
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How to Uninstall myReports

Step by Step
1) Click File > Logout The Login window appears.
2) Clear the Save Password check box.

3) Login (see How to Start myReports, as of step 2).

Related Topics
* How to Start myReports

3.5 How to Uninstall myReports

Step by Step
1) Close myReports.

NOTICE: Please make sure that you refer to the notes in the
ReadMe first file.

2) Select one of the following options:
e Windows XP: Double-click in the Control Panel on Software.
Click on the myReports item and then on Remove.

*  Windows Vista: Double-click in the Control Panel on Programs and
Features.

Click Uninstall in the context menu of myReports entry.

e Windows 7: Click in the Control Panel on Programs.
Click on Programs and Features.
Click Uninstall in the context menu of myReports entry.

3) Follow the instructions of the uninstallation program.

Related Topics
* How to Install myReports

3.6 Automatic Updates

Automatic updates ensure that myReports is always kept up-to-date with the
latest version.

If myReports determines that a newer version is available on the application
server, a corresponding message will be displayed. The automatic update is
performed on exiting myReports.

A31003-P3010-U107-17-7619, 06/2015
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3.6.1 How to Perform Automatic Updates

Prerequisites
* You have received a message such as: Client update available.
Please wait while the update is done. Please close the
following programs to continue the update: [...].
Step by Step
> Close the named programs.
Next steps

Restart myReports after the automatic update.

A31003-P3010-U107-17-7619, 06/2015
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How to Select the User Interface Language

4 First Steps

The First Steps describe the recommended actions to be taken right at the
beginning.

Select the language

Select the language of the user interface of myReports.

Configuring an E-mail Account to Send Reports by E-mail

Check if an e-main account was configured for sending reports by e-mail.

INFO: When setting up the application server, an e-mail account
is configured via which the application server can send e-mails.

The sending of reports by e-mail using myReports occurs through
either the e-mail account configured in the application server or
the e-mail account configured in myReports by the myReports
administrator.

4.1 How to Select the User Interface Language

Step by Step

1) Click on Administration > myReports Settings.

2) Select the desired language in the Language drop-down list.
3) Click Save.

4) Click File > Logout The Login window appears.

5) Log in (see How to Start myReports, as of step 2).

4.2 How to Test an E-mail Account to Send Reports

14

Prerequisites

Step by Step

* You know the data of the e-mail account that can be used to send reports.

1) Click Administration > E-mail Setup. The data of the configured e-mail
account is displayed.

2) Check whether the data is complete and correct.

A31003-P3010-U107-17-7619, 06/2015
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Next steps

Contact the myReports administrator if the displayed details are incomplete or
invalid.

A31003-P3010-U107-17-7619, 06/2015
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How to Test an E-mail Account to Send Reports

5 Reports

16

As a myReports user, you can create reports on Contact Center agents and their
activities, including calls, queues, performance, GOS (Grade of Service) and
wrap-up codes.

Reports can be created from approx. 100 predefined report templates, which are
sorted by subject area (report groups).

INFO: ltis advisable to not create reports with more than 100
pages. If required, the reporting period for the report should be
restricted accordingly.

Call History

Reports based on the call history stored in the communication system. The
maximum retention period for the call history is 365 days (default setting). The
administrator of your communication system can set the retention period for the
call history on a system-wide basis.

Example: The retention period was set to 100 days. This means that only data
that is up to 100 days old can be used for the preparation of reports.

Language

Reports are created in the language of the user interface of myReports.

Report Parameters

Before creating a report, you will need to set report parameters to define the
period (date, time) and entities (agents, queues, etc.) to be measured.
The following report parameters are available:
*  From Date
Date for the start of the reporting period
* To Date
Date for the end of the reporting period
*  From Time
Time for the start of the reporting period
e To Time
Time for the end of the reporting period

*  Queue Name
Relevant queue for the report

* Queues

Relevant queues for the report
* Agent

Relevant agent for the report
* Agents

Relevant agents for the report

A31003-P3010-U107-17-7619, 06/2015
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e User
Relevant internal subscribers for the report
e CLI

Relevant phone number of an external subscriber (customers) for the report
e CLI Fragment
Relevant phone number portion of external subscribers (customers) for the
report
¢ CustomerID
Relevant Customer ID for the report
e Wrap up Description
Relevant wrapup code for the report
¢ Wrap up Group
Relevant wrapup group for the report
* Business Hours Only
This option takes only the business hours configured in the WBM into
account.
* Daily Report
This option arranges the results of report on a daily basis.

Output Formats

You can choose between the following output formats for the report preview and
when sending reports by instant e-mail:

e Excel
« PDF
*  Word

Note that a graphical representation of the report results is not possible in the
Excel output formats.

Data Protection

When configuring myReports, the administrator of myReports can enable data
protection. This causes the last four digits of of the phone numbers (CLI column)
to be replaced by **** in all reports involved.

If the subscriber has flagged his or her private number, mobile number, external
number 1 and/or external number 2 as invisible, these phone numbers will not be
displayed in all relevant reports.

Report Manager

The Report Manager is used to manage the report templates. It shows a list of
all report templates with the following details:

¢ Identifier

¢ Report Name

¢ Report Group

You can sort the report templates by any column in ascending or descending
alphanumeric order. In addition, the Report Manager includes a drop-down list

A31003-P3010-U107-17-7619, 06/2015
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for selecting the displayed report group(s), a display indicating the number of
report templates, and the following symbols:

Symbol Function

c Refresh
n Delete Report

Select File

Add Report

You can also create additional report groups and store them in the Report
Manager.

Report Preview

If desired, you can create a report preview in one of the output formats and either
save it or open it immediately with the appropriate application.

Immediate Delivery by E-mail

You can send a report as an e-mail attachment to any desired recipient at any
time. The subject of the e-mail always begins with your last name and your e-mail
address that is configured in the communication system. You can also add
additional text to the Subject line if required.

Default Reports

The predefined report templates can be updated by a myReports administrator.

NOTICE: Note that all schedules are deleted on updating the
predefined report templates.

Related Topics
» User Interface Elements
* Schedules

5.1 Predefined Report Templates

myReports provides about 100 predefined report templates for creating reports.

These templates are classified by subject area and assigned to the following
report groups:
* Agent Activity

A31003-P3010-U107-17-7619, 06/2015
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* Agents

e CLI

¢ Call History
e Calls

¢ Fax/E-Mail
e Other

¢ Performance
*  Queues

¢ User Presence Status
¢ Wrap-up Codes

INFO: The predefined report templates cannot be edited by a
myReports user.

Updating Predefined Report Templates

Following an update to the myReports application software, some new predefined
report templates may be available. As a myReports administrator, you can update
the predefined report templates and thus make the new templates available to all
myReports users.

NOTICE: On updating the predefined reports, all schedules are
deleted.

Related Topics
* How to Update the Predefined Report Templates

5.2 How to Display a Report Preview

Prerequisites

¢ The prefixes for external phone numbers have been configured.

Step by Step
1) Click Schedule Manager.

2) Click in the Report Explorer on the desired report template in the appropriate
report group.

3) Use the report parameters to define the time period and entities to be
measured.

A31003-P3010-U107-17-7619, 06/2015
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How to Send a Report Immediately by E-mail

4
5)

6)

INFO: The report parameters depend on the selected report
template. More information on the various report parameters can
be found under Reports.

Click OK followed by OK.

Select one of the following options in the Format drop-down list:
 PDF

* XLS (Excel)

» DOC (Word)

Click the Preview Report icon. The report is then displayed in the selected
output format.

5.3 How to Send a Report Immediately by E-mail

20

Prerequisites

Step by Step

1)
2

3

4
5)

6)
7)

An e-mail account to send reports by e-mail has been configured.
Your e-mail address has been configured in the communication system.

The prefixes for external phone numbers have been configured.

Click Schedule Manager.

Click in the Report Explorer on the desired report template in the appropriate
report group.

Use the report parameters to define the time period and entities to be
measured.

INFO: The report parameters depend on the selected report
template. More information on the various report parameters can
be found under Reports.

Click OK followed by OK.

Select one of the following options in the Format drop-down list:
 PDF

e XLS (Excel)

« DOC (Word)

Click the Sending attached report file icon.

Enter the e-mail address of the desired recipient in the To field.

A31003-P3010-U107-17-7619, 06/2015
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8) If desired, enter an additional text for the Subject line of the e-mail in the
Subject field.

INFO: The subject of an e-mail always begins with your last name
and your e-mail address that is configured in the communication
system.

9) Enter the message text for the e-mail in the Message : field.
10) Click Send followed by OK.

Related Topics
+ How to Configure an E-mail Account to Send Reports
* How to Configure Prefixes for External Phone Numbers

5.4 How to Add a Report Template

Prerequisites

* A new report template (file of the type . rptdesign) is available.

Step by Step
1) Click Report Manager.
2) Click the Select File icon.
3) Choose the desired file in the file selection dialog box and click Open.
4) Select one of the following options:

* If you want to save the report template in an existing report group, select
the desired report group from the drop-down list.

* If you want to save the report template in a new report group, select the
item New Report Group in the drop-down list. Replace the entry New
Report Group in the drop-down list with the name for the new report

group.
5) Click the Delete icon, followed by OK.

5.5 How to Delete a Report Template

Prerequisites

*  You are logged on to myReports with the user name under which the report
template was added.

e The report template is not included in any schedule.

A31003-P3010-U107-17-7619, 06/2015
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Step by Step
1) Click Report Manager.
2) Select the desired report group from the drop-down list for the report groups.
3) Click in the list of report templates on the desired report template.
4) Click the Delete report icon, followed by OK.
5) Click OK.

5.6 How to Update the Predefined Report Templates

Prerequisites
* You are logged into myReports as a myReports administrator.
Step by Step
1) Click on Administration > Default Reports.
NOTICE: On updating the predefined reports, all schedules are
deleted.
2) To confirm, click OK.
Next steps

myReports exits and restarts automatically.

Related Topics
* Predefined Report Templates

A31003-P3010-U107-17-7619, 06/2015
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Schedules
How to Update the Predefined Report Templates

A schedule defines the time-controlled creation of a specific report.

Schedule Name

A schedule name consists of the name of the report in that schedule, followed by
the schedule ID.

Report Parameters

Before creating a report, you will need to set report parameters to define the
period (date, time) and entities (agents, queues, etc.) to be measured.

Time of Execution

You can configure the following execution times for the schedule:
e Start Date
The execution of the schedule is initiated on the start date.
 End Date
The execution of the schedule is repeated at the configured recurrence
intervals until the end date is reached.
e Time
The schedule is run for the first time at the time specified here.

If multiple schedules are to be run at the same time, the corresponding reports
are generated at intervals of one minute each for performance reasons. This has
no effect on the contents of the reports

Output Method

The following options are available for the output of a scheduled report:

e Delivery by E-mail
Scheduled reports can be sent to your e-mail address or the e-mail addresses
of other recipients. This requires an e-mail account to have been configured
for sending reports.
The e-mail address of a recipient can be entered manually or selected from a
drop-down list. The drop-down list contains all the internal users of your
communication system for whom e-mail addresses have been configured.

* Exporting Reports
Scheduled reports can be stored on the application server and/or any PC or
server in the network.

Recurrence

You can configure the following types of recurrence for the execution of a
schedule based on the time specified for the first execution:

e Hourly

e Daily

e Every ndays

A31003-P3010-U107-17-7619, 06/2015
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How to Update the Predefined Report Templates

24

Weekly

Every n weeks
Monthly

Every n months
Yearly

Schedule Manager

INFO: Should the scheduled report include data of a specified
time period, the time interval has to be specified within the report
parameters. Scheduled reports always include data from the start
time and date (From Time/ From Date) to the end time and date
(To Time/ To Date).

The Schedule Manager is used to create schedules and contains the following
symbols:

Symbol Funktion

Delete schedule

Edit schedule

Save schedule

Preview report

Sending attached report file

B 60| 0 | & |Ek

My Schedules

My Schedules can be used to manage your own schedules and to display a list
with the following details:

Identifier

Schedule Name

You can only view your own schedules.

Start Schedule

Start of the time period in which the schedule is executed.
End Schedule

End of the time period in which the schedule is executed.

Recurrence
Type and interval of the recurrence.

A31003-P3010-U107-17-7619, 06/2015
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You can sort the schedules by any column in ascending or descending
alphanumeric order. In addition, My Schedules contains the symbols below:

Symbol Funktion

n Delete schedule

Edit schedule
&

View Detailsmmm

& Shows the following additional information:

« Time for the first execution

* Output format

« If applicable: e-mail address of the recipient

« If applicable: further details on the recurrence

Related Topics

User Interface Elements
Reports

6.1 How to Add a Schedule

Prerequisites

Step by Step
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1)
2)

3)

4

An e-mail account to send reports by e-mail has been configured.
An e-mail template has been configured.
The data for exporting reports has been configured.

The prefixes for external phone numbers have been configured.

Click Schedule Manager.

Click in the Report Explorer on the desired report template in the appropriate
report group.

Use the report parameters to define the time period and entities to be
measured.

INFO: The report parameters depend on the selected report
template. More information on the various report parameters can
be found under Reports.

Click OK followed by OK.
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5) Select the item New Schedule in the Schedules for selected report drop-
down list.

6) Enter the start date for the execution of the schedule in the Start Schedule
field or click the adjacent calendar icon and select the desired start date in the
calendar.

7) Enter the end date for the execution of the schedule in the End Schedule field
or click the adjacent calendar icon and select the desired end date in the
calendar.

8) Select the time for the execution of the schedule in the Run this scheduled
task at list box.

9) Select one of the following options in the Format drop-down list:
 PDF
e XLS (Excel)
* DOC (Word)

10) Select the Recurrence check box.

11) Select one of the following options for the recurrence interval as well as any
other details that may be required:

* Hourly Recurrence
* Daily Recurrence
*  Weekly Recurrence
* Monthly Recurrence
* Yearly Recurrence
12) Select one of the following options for the output method:
* If you want to export the reports, enable the option Export Report.

* If you want to send the reports by e-mail, proceed as follows:

Enable the option Send the report to the user's email address Click on
the magnifying glass icon to define the e-mail address(es) to which the
reports are to be sent. The Email recipients window is displayed. You
have the following options:

— If you want to send the reports to your e-mail address configured in the
communication system, select the check box next to your name.

— If you want to send the reports to an internal subscriber of your communications
system, select the desired subscriber in the drop-down list and click on the Plus
symbol to transfer the entry to the list of e-mail recipients.

Repeat the process if you want to send the reports to other internal subscribers.

— If you want to enter the e-mail address of a recipient manually, enter it into the
input field. Click on the Plus symbol to transfer the entry to the list of e-mail
recipients.

Repeat the process if you want to enter further e-mail addresses manually.

Click OK.
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13) Click the Save Schedule icon. The data of the new schedule is then

displayed.

14) Click Save.

Related Topics

How to Configure an E-mail Account to Send Reports
How to Configure an E-mail Template in Text Format
How to Configure an E-mail Template in HTML Format
How to Configure Prefixes for External Phone Numbers

6.2 How to Display the Details of a Schedule

Step by Step

1)
2

3
4
5)

Click My Schedules.

Select the appropriate report group or the item (All Reports) in the drop-down
list.

Click on the desired schedule.
Click the View Details icon.
Click OK.

6.3 How to Edit a Schedule

Step by Step
1)
2)

3)
4)
5)

6)
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Click My Schedules.

Select the appropriate report group or the item (All Reports) in the drop-down
list.

Click on the desired schedule.
Click the Edit Schedule icon.

If you want to change the report parameters, click on the Report Parameters
icon. Edit the desired report parameters.

INFO: The report parameters depend on the selected report
template. More information on the various report parameters can
be found under Reports.

Click OK followed by OK.

If you want to change the start date, enter the start date for the execution of
the schedule in the format MM/DD/YYYY in the Start Schedule field or click
the adjacent calendar icon and select the desired start date in the calendar.
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7) If you want to change the end date, enter the end date for the execution of the
schedule in the format MM/DD/YYYY in the End Schedule field or click the
adjacent calendar icon and select the desired end date in the calendar.

8) If you want to change the execution time of the schedule, select the desired
execution time for the schedule in the Run this scheduled task at list box.

9) If you want to change the output format, select one of the following options in
the Format drop-down list:

PDF
XLS (Excel)
DOC (Word)

10) If you want to change the recurrence interval, select one of the following
options for the recurrence interval as well as any other details that may be
required:

Hourly Recurrence
Daily Recurrence
Weekly Recurrence
Monthly Recurrence

Yearly Recurrence

11) If you want to change the output method, select one of the following options:

If you want to export the reports, enable the option Export Report.

If you want to send the reports by e-mail, proceed as follows:

Enable the option Send the report to the user's email address Click on
the magnifying glass icon to define the e-mail address(es) to which the
reports are to be sent. The Email recipients window is displayed. You
have the following options:

If you want to send the reports to your e-mail address configured in the
communication system, select the check box next to your name.

If you want to send the reports to an internal subscriber of your communications
system, select the desired subscriber in the drop-down list and click on the Plus
symbol to transfer the entry to the list of e-mail recipients.

Repeat the process if you want to send the reports to other internal subscribers.

If you want to enter the e-mail address of a recipient manually, enter it into the
input field. Click on the Plus symbol to transfer the entry to the list of e-mail
recipients.

Repeat the process if you want to enter further e-mail addresses manually.

Click OK.

12) Click the Save Schedule icon. The data of the edited schedule is then
displayed.

13) Click Save.

28
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6.4 How to Delete a Schedule

Step by Step
1) Click My Schedules.

2) Select the appropriate report group or the item (All Reports) in the drop-down
list.

3) Click on the schedule to be deleted.
4) Click the Delete Schedule icon, followed by OK.
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7 Configuration

You can configure myReports in accordance with your requirements. Note that
some functions can be performed only by the myReports administrator.

7.1 Configuration by the myReports User

As a myReports user, you can customize myReports to suit your requirements via
the following settings:

Language of the User Interface

Select the language of the user interface.

Color of the user interface

Select the color of the user interface.

E-mail Template

INFO: The administrator password must be entered to configure
the e-mail template

In the e-mail template you can configure the Subject and the message text for all
e-mails with which reports are sent by myReports. The following formats can be
used for the e-mail template:

e Text
e HTML

The following placeholders can be used in an e-mail template with the text format:

Placeholder Meaning

{1} Report Name
{2} Sent By

The following English e-mail template in text format is available by default:

Subject: Business report — {1}

Message: Dear recipient(s),
This is the scheduled report: {1}.
Regards

{2}

server address

You can change the server address (IP address).
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NOTICE: Do not change the server address unless you are
instructed to do so by the administrator of your communication
system. You cannot use myReports with an invalid server
address.

7.1.1 How to Change the Language of the User Interface

Step by Step

1)
2
3
4)
5)

Click on Administration > myReports Settings.

Select the desired language in the Language drop-down list.
Click Save.

Click File > Logout The Login window appears.

Log in (see How to Start myReports, as of step 2).

7.1.2 How to Change the Color of the User Interface

Step by Step

1)
2
3
4)
5)

Click on Administration > myReports Settings.
Enable the radio button of the desired design.
Click Save.

Click File > Logout The Login window appears.

Log in (see How to Start myReports, as of step 2).

7.1.3 How to Configure an E-mail Template in Text Format

Prerequisites

Step by Step

1)
2

3)
4)

You know the administrator password.

Click Administration > E-mail template.

Enter the administrator password and click OK.

INFO: The default administrator password is reports.

Enter the desired text in the Subject field.

Enter the desired text in the Message field.
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5) Click on Save and then on Cancel.

Related Topics
* How to Add a Schedule

7.1.4 How to Configure an E-mail Template in HTML Format

Prerequisites
* An appropriate HTML file (*.htm or *.html) is available.

*  You know the administrator password.

Step by Step
1) Click Administration > E-mail template.

2) Enter the administrator password and click OK.

INFO: The default administrator password is reports.

3) Click the Browse HTML formatted message icon.
4) Choose the desired file in the file selection dialog box and click Open.

5) Click on Save and then on Cancel.

Related Topics
+ How to Add a Schedule

7.1.5 How to Change the Server Address

Prerequisites
* myReports was started.

* A new server address (IP address) is available.

NOTICE: Do not change the server address unless you are
instructed to do so by the administrator of your communication
system. You cannot use myReports with an invalid server
address.
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Step by Step
1) Click File > Logout The Login window appears.
2) Enter your user name in the Login Name field if it is not shown.
3) Enter your password in the Password field if it is not shown.

4) If you want to use myReports with an automatic login in the future, enable the
Save Password check box. The Login window will then no longer be
displayed. You can change this option at any time; see How to Deactivate the
Automatic Login.

NOTICE: You should use the automatic login only if you are
certain that no-one else has access to your Windows user
account. Otherwise, unauthorized users could, for example,
potentially access your voicemails and fax messages or redirect
your station number to external toll-based destinations.

5) Enter the new IP address in the Server IP field.
6) Click Login.

7.2 Configuration by the myReports Administrator

As a myReports administrator, you can configure myReports via the following
settings:

Administrator Password

Changing the password for the myReports administrator. The default login name
is Administrator, and the default password is reports.

INFO: The administrator of your communication system can reset
the administrator password via the WBM.

Configuring an e-mail account to send reports by e-mail

In order to enable myReports to send reports by e-mail, access to an already
existing e-mail account must be configured. This configuration (for sending e-
mails) usually takes place when setting up the application server. The e-mail
delivery of reports by myReports occurs via this configured e-mail account.

Configure access to an existing e-mail account in myReports if
* no e-mail account for sending e-mails was configured during the setup of the
application server

* the e-mail account to be used for sending reports via myReports is not the
same as the one configured in the application server.
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Prefixes for External Phone Numbers

In order to enable myReports to handle different types of connections (for
example, international calls or calls from mobile phones), you must configure the
appropriate prefixes for external call numbers.

The following prefixes for external phone numbers can be configured:

Type Examples Considered in the following predefined
report templates (examples)
International 00 Incoming Calls (International)-Per User
Outgoing Calls (International)-Per User
Mobile/Cell 14;15;16 Incoming Calls (Mobile-Cell)-Per User
Outgoing Calls (Mobile-Cell)-Per User
Free Call 0800 Incoming Calls (Free-Calls) - Per User
Outgoing Calls (Free-Calls)-Per User
Pay Call 0900;0901 Outgoing Calls (Pay-Calls)-Per User
Call to special 01;123 Incoming Calls (Specific Calls)-Per User
phone numbers Outgoing Calls (Specific Calls)-Per User

Data Protection

You can enable Data Protection. This causes the last four digits of of the phone
numbers (CLI column) to be replaced by **** in all reports involved. This also
applies to reports that are created with myAgent.

Exporting Reports

You can configure the storage location for exporting scheduled reports.
Scheduled reports can be stored on the application server and/or any PC or
server in the network.

Languages

INFO: In order to configure the languages, you will need to enter
a special password.

By default, several different languages are available for the user interface and
report templates of myReports. To customize myReports for your specific
requirements, you can:

¢ Add languages for the user interface and report templates. You can do this in
the following ways:

— Import texts of the new language via a CSV file
The texts of the new language must be available as a CSV file in the
format shown in the following example. Note that only one language can
be imported at a time, and that the texts of this language must always be
in the third column, next to the English language. In the following
example, the language Svenska (Swedish) can be imported.

A31003-P3010-U107-17-7619, 06/2015
myReports, User Guide



Configuration
Configuration by the myReports Administrator

[A] B 1 c

1 |ID English Svenska

2 1 Login Name Inloggningsnamn

3 | 2 Password Lésenord

4 | 3 Language Sprak
5 | 4 Login Inloggning

6 5 Quit Sluta

7 | 6 Disconnected Frankopplad

8 7 Connected Ansluten

9 | 8 Welcome to myReports Vélkommen Till myreports
10| 9 ServerlP Server ip

11| 10 Save Password Spara Losenord
12 | 11 " This operation is not yet available * Denna Operation &r Annu Inte Tillgénglig
13 | 12 myReports myreports

14 | 13 Version Version

15 | 14 contributors and others. All rights reserved. Bidragsgivare och Andra. Alla Réttigheter Reser
16 | 15 Please select the report first! Vilj den Rapport Forst!
17 ! 16 Report Manager Report Manager

18 | 17 Modules. Moduler.
19 | 18 Schedule Manager Schema Chef

20 | 19 Report Paramelers Rapportparametrar

21| 20 User Anvéndare

22 | 21 Logout Logga ut

23 | 22 Stalus Status

Due to the import, the language table is extended by one column.

— Translate texts for the new language using Google Translator
The language table is extended by one column and populated with
suggested translations for the new language from Google Translator.
These suggested translations are based on the standard texts of the
English user interface and report templates.

— Enter texts for the new language manually
The language table is extended by an empty column, and you can enter
the texts for the new language in the empty cells.

You can edit the text in any cell of the language table by simply double-clicking

on that cell.

By selecting Edit > Find and Replace, you can also find any term in the

language table and replace it with some other term.

Delete languages of the user interface and report templates.

If you do not want a particular language of the Ul to be made available to the

myReports users, you can simply delete that language.

Save the language texts of the user interface and report templates in a CSV

file.

You can save the current language texts of all languages in a CSV file.

Default Languages

You
tem

INFO: In order to reset the languages (Default Language
Setup), you will need to enter a special password.

can reset (reinitialize) the languages of the user interface and report
plates to repair or restore a missing language, for example.

A reset results in a restart of myReports. Following the restart, all the default
languages will available again to all the myReports users.
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7.2.1 How to Change the Administrator Password

Prerequisites

Step by Step

1)
2

3)

4)

You are logged into myReports as a myReports administrator.

Click Administration > Management.

Enter the current administrator password in the Administrator Password
field.

Enter the new administrator password in the Administrator Password and
Re-enter Password fields.

Click Save.

7.2.2 How to Configure an E-mail Account to Send Reports

36

Prerequisites

Step by Step

1)
2

3
4
5)

6)

7)

INFO: The configuration of an e-mail account to send reports by
e-mail is only required in the following cases:

No e-mail account was configured during the initial setup of the
application server.

The e-mail account to be used for sending reports via myReports
is not the same as the e-mail account configured in the application
server.

You are logged into myReports as a myReports administrator.

You know the login data of an e-mail account that can be used by myReports
to send reports by e-mail.

Click Administration > E-mail Setup.

Enter the server name or the IP address of the E-mail server in the E-mail
Host field.

Enter the user name of e-mail account in the E-Mail User field.
Enter the password of the e-mail account in the E-mail Password field.

In the field E-mail From, enter the e-mail address that is to be displayed as
the sender.

In the field E-Mail Reply To, enter the e-mail address that is to be displayed
as the Reply To address.

Click Edit.
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8) Enter the administrator password and click OK.
9) Click Save.

Related Topics
*+ How to Send a Report Immediately by E-mail
* How to Add a Schedule

7.2.3 How to Configure Prefixes for External Phone Numbers

Prerequisites

* You are logged into myReports as a myReports administrator.

Step by Step
1) Click Administration > Phone Numbers.

2) Enterthe prefix or prefixes for international numbers in the International field.

INFO: Multiple prefixes can be entered in one field by separating
the entries With ll,ll’ |l;ll, ll_ll, ll.ll, ll_ll Or lllll.

After the phone number prefixes have been saved, they are
displayed with a ";" as the separator, regardless of which
separator you entered.

3) Enter the prefix or prefixes for national mobile numbers in the Mobile field.
4) Enter the prefix or prefixes for toll free numbers in the Free Call field.
5) Enter the prefix or prefixes for toll numbers in the Pay Call field.

6) Enter the prefix or prefixes for special phone numbers in the Specific Call
field.

7) Click Save.

Related Topics
* How to Send a Report Immediately by E-mail
+ How to Add a Schedule

7.2.4 How to Activate or Deactivate Data Protection

Prerequisites

* You are logged into myReports as a myReports administrator.
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Step by Step

1) Click on Administration > Data Protection.

2) Select one of the following options:

If you want to enable data protection, select the CLI Fragmentation
check box.

In all reports involved, the last four digits of of the phone numbers (CLI
column) are replaced by ****.

If you want to disable data protection, clear the CLI Fragmentation check
box.

In all reports involved, the last four digits of of the phone numbers (CLI
column) are displayed fully.

3) Click Save.

7.2.5 How to Configure the Storage Location for Exporting Scheduled

Reports
Prerequisites
Step by Step
38

1)
2)

3)

You are logged into myReports as a myReports administrator.

Click on Administration > Export Report.

If scheduled reports are to be stored on the application server, select the
Enable export check box.

a)

In the field System Directory enter the storage path where the scheduled
reports are to be stored.

The default storage path is /var/reports.

If scheduled reports are to be stored on a PC or server in the network, select
the check box Enable Remote Export.

a)

b)

c)

d)

In the field Remote Host, enter the IP address of the network PC or
server where the scheduled reports are to be stored.

In the field Remote Port, enter the port of the network PC or server that
is to be used for the export.

Enter the user name for accessing the PC or server on the network in the
User Name field

Enter the password for accessing the PC or server on the network in the
Password field.

In the field Remote Directory enter the storage path where the scheduled
reports are to be stored.

Select one of the following protocols for the export:
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— If you want to use the SMB (Server Message Block) or CIFS (Common
Internet File System) protocol, select the item SMBJ/CIFS in the Protocol
drop-down list.

— If you want to use SFTP (Secure File Transfer Protocol), select the item
SFTP in the Protocol drop-down list.

NOTICE: To enable the remote export, the PC or server in the
network must also support the protocol selected here.

If required, the ports used for the export must be opened on the
PC or server in the network. By default, ports 22 (when using the
SFTP protocol) and 445 (when using the SMB/CIFS protocol) are
used.

Click Save.

7.2.6 How to Add a New Language for the User Interface and Report

Templates
Prerequisites
Step by Step
1)
2)
3)

4)

5)
6)
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You know the password for configuring the language.

The current language texts of the user interface and report templates were
saved in a CSV file (see How to Export the Language Texts of the User
Interface and Report Templates).

The texts of the new language are available or known to you. (in case the texts
of the new language are to be added manually or translated using the Google
Translator).

The CSV file is available to use (in case the texts of the new language are to
be imported via a CSV file).

Click Start > Program Files > Communication Clients > myReports. You
will then be presented with the login screen.

Enter Administrator in the Login Name field.

Enter the password for configuring the language in the Password field. If you
have any questions, please contact the administrator of your communication
system.

In the Server IP field, enter the IP address of your application server (if this is
not already displayed.

Click Login.

Click on Administration > Language Setup. A table with the texts of the user
interface and the report templates in the currently available languages is
displayed.
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7) Select one of the following options to add the new language for the user
interface language and for report templates:

If you want to import the texts of the new language from a CSYV file,
proceed as follows:

Click on File > Import from CSV.

Select the desired new language in the New Language drop-down list
and click on Browse. Navigate to the storage location of the desired CSV
file and click OK & Next. The table is then extended by one column, and
the input fields of the new language are filled with the contents of the CSV
file.

Click Save.

Click OK followed by Cancel.

If you want to have the texts of the new language translated by Google
Translator, proceed as follows:

Select the desired new language in the New Language drop-down list.
Select the Use Google Translator check box.

Click the Plus icon. The table is then extended by one column and
populated with suggested translations from the Google Translator for the
new language. These suggested translations are based on the standard
texts of the English user interface and report templates.

Check the proposed translations and correct or complete them as
required.

Click Save.

Click OK followed by Cancel.

If you want to enter the texts of the new language manually, proceed as
follows::

Select the desired new language in the New Language drop-down list.
Clear the Use GOOGLE Translator check box.

Click the Plus icon. The table is then extended by one column.

Enter the texts of the new language in the appropriate fields.

Click Save.

Click OK followed by Cancel.

8) If you want to use the new language as default language, select the new

language in the Default Language drop-down list.

9) Click OK.

10) Click Close.
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7.2.7 How to Delete a Language for the User Interface and Report Templates

Prerequisites

Step by Step
1)

2)
3)
4)
5)

6)

7)
8)
9)

You know the password for configuring the language.

The current language texts of all languages for the user interface and report
templates were saved in a CSV file (see How to Export the Language Texts
of the User Interface and Report Templates).

Click Start > Program Files > Communication Clients > myReports. You
will then be presented with the login screen.

Enter Administrator in the Login Name field.

Enter the password for configuring the language in the Password field. If you
have any questions, please contact the administrator of your communication
system.

In the Server IP field, enter the IP address of your application server (if this is
not already displayed.

Click Login.

Click on Administration > Language Setup. A table with the texts of the user
interface and the report templates in the currently available languages is
displayed.

Select the desired language in the Delete Language drop-down list.
Click on the Trash Can icon, followed by OK.
Click Save.

10) Click OK followed by Cancel.
11) Click Close.

7.2.8 How to Export the Language Texts of the User Interface and Report

Templates
Prerequisites
Step by Step
1)
2)
3)
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You know the password for configuring the language.

Click Start > Program Files > Communication Clients > myReports. You
will then be presented with the login screen.

Enter Administrator in the Login Name field.

Enter the password for configuring the language in the Password field. If you
have any questions, please contact the administrator of your communication
system.
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4

5)

6)

7)

8
9)

In the Server IP field, enter the IP address of your application server (if this is
not already displayed

Click Login.

Click on Administration > Language Setup. A table with the texts of the user
interface and the report templates in the currently available languages is
displayed.

Click on File > Export to CSV. The contents of the CSV file myReports-
Languages . csv are then displayed in the editor.

Save the CSV file in the desired directory and close the file.
Click Close.

7.2.9 How to Reset All Languages of the User Interface and Report

Templates
Prerequisites
Step by Step
42

1)

2)

3)

4)

5)
6)

7)

You know the password for configuring the default language.

The current language texts of the user interface and report templates were
saved in a CSV file (see How to Export the Language Texts of the User
Interface and Report Templates).

Click Start > Program Files > Communication Clients > myReports. You
will then be presented with the login screen.

Enter Administrator in the Login Name field.

Enter the password for configuring the language in the Password field. If you
have any questions, please contact the administrator of your communication
system.

In the Server IP field, enter the IP address of your application server (if this is
not already displayed.

Click Login.

Click on Administration > Default Language Setup.

NOTICE: The Default Language Setup function resets
(reinitializes) the languages of the user interface and report
templates. Only the default languages will then be available for
the user interface and report templates.

Click OK. myReports then performs a reboot.
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Next steps

Log into myReports and add any further languages for the user interface and
report templates as desired (see How to Add a New Language for the User
Interface and Report Templates).
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8 Appendix

The Appendix provides information on the different user roles and their
differences and on the database tables available in myReports.

8.1 myReports User Roles

myReports has its own user management, which controls access to the functions
of myReports through user roles. A distinction is made here between the
myReports users (standard user) and the myReports administrator.

Your current user role is set when you log into myReports.
* Logging in as a myReports user:
— Login Name: This is usually your station number
— Password: The default password is 1234.
* Logging in as a myReports administrator:
— Login Name: The login name is Administrator.
— Password (Administrator Password): The default password is reports.

The differences between the roles are summarized in the following table.

myReports: User Role
Activity myReports myReports
User Administrator

Reports

Preview report X X

Send report immediately by e-mail X X

Add report template X X

Delete added report template X X

Define new report template X

Update predefined report templates X
Schedules

Add a schedule X X

Display details of a schedule X X

Edit schedule X X

Delete schedule X X
Configuration
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myReports: User Role
Activity myReports myReports
User Administrator

Change language of user interface X X
Change color of user interface X X
Configure e-mail template X1 X
Change server address X X
Change administrator password X
Configure e-mail account to send reports X

by e-mail

Configure prefixes for external phone X
numbers

Enable/disable data protection X
Configure the storage location for the X
export of scheduled reports

Add or delete language X2
Reset languages X2

N

The administrator password must be entered to configure the e-mail template
In order to add or delete a language and reset all languages, you will need to log in as a myReports

administrator with a special password.

8.2 myReports Data Relationship Model

The model shows all database tables and their relationships.
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thiswitches thicallhistory thlusers thlagentactivity
switch_id serial ch_call_id serial user_id serial 2a_id serial
switch_type intd ch_switch_id intd user_login warchar (50) aa_agert_id intd
switch_settings varchar (255) oh_local_id intd user_password varchar (50) =a_queus_id int4
smitch_deseription warehar (255) ch_user_id intd user_firstname wvarchar (50) 2a_call_dirsction  ind
switch_bargein_prefix warehar (30} ch_calling_number  varchar (20) user_surname wvarchar (50) h 2a_call_id intd
switeh_pickup_prefix varchar (30) ‘_ ch_called_number varchar (20 _’ user_active intz =a_svert_hpe  intd
switch_ssternal_prefix warehar 30y fk ch ch_diraction intz fk ch user_smail varchar 70) fk_aa, 2a_evert fime  fimestamp
switch_esternal_min_length  intd switch id ch_internal_external  int2 user id user_extension warchar (10 aa_event_data  varchar (2147483647)
switch_parkslols warchar (100 - ch_start_time timestamp user_level inz
switch_setmw_prefix warehar (30} ch_end_time timestamp user_switch_id intd
Switoh_sanoel mw_prefix warchar (30} oh_talk_fime_seconds  intd user_virtual_status inta
switch_sxtension_length int4 ch_contact_cache_id  int® user_virtual_todate warchar (12) thlvoicemail
switch_password_langth int4 oh_sonversation_jd  intd user_contact_external warchar (25) —_— o
switch_office_start warehar (4 -
¢ x “@ user_contact_externalz warchar (251 e B inth
switch_office_snd varehar (4 i

¢ :_¢ “ user_sontact_mobile warchar (25) e timestamp
switsh_operator_number warehar (10

_op " 10y — user_sontact_home varchar (25) ©n_status o
switch_voicemail_huntgroup  varehar (10} thluseractivity user_contact_fax varchar (25)

- - wm_ealling_umber warehar (30}

switch_operstor_extension  varehar (101

_Op! ¢ am * ua_id serial user_contact_assistant varchar (25) win_pririty int2
smitch_mode_day warehar (10} oL intd user_contast_vaicemail varchar (25) h N -
switeh_mads_night warchar (10 ] ] ﬁ i i -

\ gt i (10 L _time Himestamp user_directory_listed int4 fk vm_group id -
switch_internationsl_code  varchar (101 i

i . ) ua_method intd tbluseractivity user_autoback_office intd _vrn__ W Cr teoReeohe Rl ints

switch_liverecord_button  intd . -

¥ t A office_stetus  intd ua_user id_fkey user_autalagon intd user_id vm_sonversation_id it

switch_country_code warehar (10} La_status_data  varchar (20) — —H user_aseess details intd o etatue umer i it
swilch_area_code warchar (10 - -

_area_r 10y user_avoess_messages int4 rntpe _—

amitch_ucd_pilot warehar (15
_ucd_pi 15) user_service_terminal_serder  intd L o
switch_meb_seftings varehar (255
_rheb_: 2 255) user_message_mait_type it Nt o intz
switch_access_code warehar (15)
_ . , thlqueues user_meszage_outbound wvarchar (50) e T B
user_notification_status_0 int4
queue_id serial - -
fk_queue_ har 2147 304T) user_nofification_status_1 intd
y ; queus_name warchar
switch_id e -~ user_nofification_status_2 intd
fk_call - i
o R — i user_nofification_status_3 intd thidepartments
switch_l user_netification_status_4 inta
CEEINEED i user_notific ation_status_§ ina . ! deparmart Jd serial
thicalls euE_Fen i LA inta AT GELELEN(ED
queus_schedule_id int4 - - department_hunigroup varchar (10
¢ oall_id I tificatien_status_7 14 thlusers_ =
call_j serial S e user_notification_status in o
call_switch_id intd user_notification_status_8 intd —

= - queus_zlsrm_sall_sount int4 - - department
oall_jocal_id intd user_department_id int4

- queus_slarm_call_time int4 - - ) =
call_type int4 user_message_wait_extension warchar (10 id_fke:

i queue_uwrapup it d BRIEY oy _Tkey thicustomers
call_start_time timestamp AR i user_profile_image varchar (258) - -
oall_end_time timestamp user_is_agert inta Custorertid (2

queue_screenpep_timeout int4 ==
call_calling_number  varchar 50 - - user_is_attendant intd customer_businass warchar (50)
call_called_number  varchar (50 ueuEva oRelle_prionity e user_js_voicamsil inta customer businessz varchar (50)

= - queus_callbackealls_priority int4 5
call_sonneoct_time timestamp user_forward_status_1 intd CrEImE[eme varehar (50)

= = queus_faxealls_priority int4 - = -
call_direction in2 _ i} . user_forward_status_2 intd OETmE s varehar (50)
ol intent e queus_emailozlls_priority int4 N o TS N

= queue_email_reply_address warchar (503 - = =
call_contact_cache_id it user_forward_status_4 intd Or=tme{IEREe TEEE(ED)
= S = queue_search_last_agent int4 = 5 5
user_forward_status. 5 -~ customer_sumame warchar (50)
queue_sbandoned_calls_threshold  intd i - sustomer_sampany ustohar (255
queue_hurtgroup_is_tcd o> o G CEE. S - customer_sdemal_id warchar (255)
queus_wrapup_mode (i e _— custamer_exernal_source  int2
fh_cc_ fh_cc_ fk_aq e - - customer_last_modified i
call_id queus_id == -
- queue_id user_liverecord_buttan inta. prr—
- reakscc
blcallsce user_calendar_integration  intd
thlagentqueues user_play_through_speakers  in2 break_id =zerial
* caedlLiE D aq_user_jd it ‘ﬁ user_esternal_id varchar (128) break_name varchar (255)
©c_queue_id intd aq_queus_id intd fk_aq_ break_default_interval_mindes  intd
oo_agert_id intd 2q_agent_type intd user_id break_active intd
oo_queus time Loty aq_skill_level intd
©o0_pickup_time intd aq_oallback intd thiconfig
LI e aq_start_calls it f_psram_nsme warchar(100)
e e Salstaitasccandeinty of_param_value warchar (255)
co_gos intd -
aq_wor kti me intd of_param_description  warchar (255)
co_wrapup_id int4
co_liveresorded intd
oo_oallback_number  varchar (100) thiwrapupec thiwrapupgroups
thlccwrapups_ thlcewrapups thlccwrapups
co_data text (2147483647} : ! — wrapup_code sarial + wg_id serial
- cew_ce_id_fkey cow_we_id_fkey .
co_sompleted intd - == serial = M WrEpup_queue_id intd wg_queue_id intd
oo _fax intd _ eom_ce_id int3 ﬁ- wrapup_description  warchar (2147423647) wy_caption warchar (265)
oo_email intd con_we_id intg wrapup_parent_id ints wg_parert_id ints
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